Vul hieronder je gebruikernaam en wachtwoord in.

Is iOS 10.3 de laatste versie voor 32-bits iDevices? (Upd.)

008

Apple had nog maar net de updates voor iOS, watchOS, macOS en tvOS uitgebracht en de beta-versies voor de volgende updates stonden alweer klaar voor ontwikkelaars. Als zo'n beta-update zo snel volgt op een grote update dan zijn daar meestal geen spectaculaire dingen over te melden, maar bij iOS 10.3.2 beta lijkt dat nu wel het geval.

Want van deze versie staan alleen versies klaar voor 64-bit devices, het lijkt er op dit moment dus op dat 10.3 de laatste versie wordt die op 32-bits iDevices gebruikt kan worden.

Citaat:



Als dit klopt dan zou iOS 10.3 de laatste versie van iOS zijn die nog zal draaien op de iPhone 5, 5c of de vierde generatie iPad. Dat zou opvallend zijn, want 'normaal gesproken' stopt Apple pas met het ondersteunen van bepaalde devices als er een compleet nieuwe versie van een besturingssysteem uitkomt.

De verwachting was dan ook dat bij de WWDC, bij de aankondiging van iOS 11, duidelijk zou worden welke devices dit keer 'de klos' zouden zijn. Maar dat is natuurlijk geen wet van Meden en Perzen, Apple heeft nu eenmaal altijd de mogelijkheid om bij een update ondersteuning voor oudere devices te stoppen.

Of de ondersteuning voor 32-bits devices nu echt gestopt is, dat is nog niet bekend. En als dat zo is, dan is ook nog niet duidelijk wat de (technische) reden daarvoor is. Als dat wel duidelijk wordt dan is dat natuurlijk op MacFreak te lezen.

9,7-inch iPad

Toen Apple recent de nieuwe 9,7-inch iPad uitbracht werd al gespeculeerd dat wel een de beoogde upgrade zou kunnen zijn voor veel mensen met een ouder model iPad. Het stoppen van toekomstige upgrades voor iOS zou deze mensen mogelijk over kunnen halen om eerder voor een recentere iPad te kiezen.

Update: inmiddels is de public beta versie van iOS 10.3.2 uit, die is te vinden via deze pagina van Apple. Die verschilt niet van de versie die eerder deze week voor ontwikkelaars beschikbaar werd, dus ook deze is niet geschikt voor 32-bits devices.

Reacties

29 maart 2017 Een ware MacFreak!

Dat wisten we natuurlijk al een tijdje.

32-bit devices moeten updaten via iTunes want via WiFi op de telefoon zelf komt er te staan dat je gewoon up to date bent met iOS 10.2.1.
Vanaf iOS 11 zal het helemaal over en uit zijn.

29 maart 2017 MacFreak Verslaafde

Van 32 bit wordt op alle platformen geleidelijk afscheid genomen. Het hoort natuurlijk bij Apple om dit als eerste te doen.
Ik denk dat de 10.3.2 update een soort transitie update wordt, zodat de basis gelegd is om iOs 11 te installeren.
Een beetje zoals Apple het bij de volledige overgang naar 64-bit Mac os X heeft gedaan. (Snowleopard en Lion)

29 maart 2017 Een ware MacFreak!

Ik kan 10.3 niet installeren op mijn 5C, hij geeft aan dat mijn software up-to-date is met 10.2.1

29 maart 2017 Een ware MacFreak!

Je moet met je iPhone 5c via iTunes updaten. Ik had hetzelfde probleem en het lijkt erop dat Apple de 10.3 update alleen beschikbaar heeft gemaakt via WiFi voor 64-bit devices. Dit zijn van die Apple maniertjes die je nooit uit het bedrijf krijgt. Je hebt kans dat ze natuurlijk over 3 dagen de update wel toevoegen via WiFi omdat iedereen dan al lang heeft geüpdatet en ze straks natuurlijk met adoption rate cijfertjes moeten goochelen over hoeveel mensen upgraden.

Het enige lelijke aan dit is niet dat bepaalde devices buiten de boot vallen, dat is prima en dat hoort erbij maar vooral dat heel veel splinternieuwe coole hippe dingen die Apple probeert te verkopen tegenwoordig afhankelijk zijn van een iPhone. En daar stond op de website toen je het kocht niet bij als minimale vereiste een iPhone met 64-bit ondersteuning maar gewoon een iPhone met het laatste OS.
Jij kunt dus een paar maanden geleden een Apple Watch en AirPods gekocht hebben met de veronderstelling dat deze fijn zouden werken want je voldeed aan de minimale eisen iPhone of iCloud account en dan blijkt nu (binnenkort) dat je deze splinternieuwe hippe producten niet meer kunt updaten omdat je telefoon 32-bit is. Dus je moet eerst een 64-bit telefoon kopen om die hippe gerelateerde spulletjes te kunnen updaten.

Ik geef een voorbeeld. Apple Pay. Dat zou functioneren wanneer je een iPhone 5c (not compatible) en Apple Watch (wel compatible) bezit. Kortom als je een Apple Watch hebt zou je dus eigenlijk geen nieuwe telefoon met die ondersteuning hoeven te kopen want als je nu je telefoon of je horloge bij de terminal gaat houden dat maakt niet zoveel uit. Dan wordt Apple Pay straks gelanceerd en kun je die Apple Watch niet gebruiken voor deze dienst want je kan de Apple Watch niet updaten vanwege je oude iPhone terwijl dat horloge gewoon alles bevat om deze dienst te ondersteunen en het op die manier nu ook prima werkt alleen niet in Nederland omdat deze banken natuurlijk niet toegevoegd zijn.

Dit is weer typisch Apple misleiding waar ze mee wegkomen omdat het op een manier vriendelijk gedaan wordt. Op de Apple manier en dan is het geen misleiding maar bijvoorbeeld betere voor je veiligheid en courage van het bedrijf.

Marketing op z'n best.



29 maart 2017 Een ware MacFreak!

Citaat: alfasud1972 om 17:05, 29-03-2017
Ik kan 10.3 niet installeren op mijn 5C, hij geeft aan dat mijn software up-to-date is met 10.2.1


Het wil ook nog wel eens gebeuren dat een device een update niet meteen 'ziet', maart later wel.

Had ik gisteren nog met mijn Apple Watch.

29 maart 2017 Redactielid

Citaat: alfasud1972 om 17:05, 29-03-2017
Ik kan 10.3 niet installeren op mijn 5C, hij geeft aan dat mijn software up-to-date is met 10.2.1


De oplossing hiervoor vind je in dit nieuwsbericht.

Er is een update bij dit nieuwsbericht geplaatst.

18 mei 2017 Een ware MacFreak!

http://tidbits.com/article/17235

Citaat:
TidBITS News Shows How an Old 32-bit iOS App Becomes 64-bit

As Adam explained in “Apple to Deprecate 32-bit iOS Apps” (15 May 2017), Apple has been slowly tightening the noose on 32-bit apps, first introducing 64-bit processors in new devices, then requiring that newly submitted apps include a 64-bit “slice,” then permitting submission of apps without a 32-bit slice, and now warning users that 32-bit-only apps won’t run in future systems. You may even now be seeing some favorite old app threatened with extinction. And you may be wondering why the developer doesn’t just update it for 64-bit and keep it alive.

Reageer

Je moet ingelogd zijn om te kunnen reageren. Als je nog geen lid bent van MacFreak kan je je hier registreren.