VM Snow Leopard gebruiken op High Sierra
geplaatst: 26 maart 2020 - 16:56
Allereerst:

Ik ben een complete leek. Totaal. Ik weet niks van programeren, kabels en software. Ik kan wel redelijk googlen en daarmee kom ik meestal een heel eind, alleen nu zit ik dus op een dood spoor.

Wat wil ik?
- Zoo Tycoon spelen, normaal ben ik werkzaam in een dierenpark, maar zoals jullie waarschijnlijk hebben meegekregen is alles dicht en zit ik dus verveeld thuis. Zoo tycoon leek mij de perfecte afleider voor de aankomende maanden. Nadeel is dat het een oud spel is en dat er maar een beperkte oplage is geweest voor de Mac, maar met heel veel geluk heb ik er toevallig via marktplaats eentje kunnen kopen. Deze is dus speciaal voor de Mac ipv Windows.

Wat ging er fout?
Het spel is al wat ouder, en na een beetje google werk kwam ik erachter dat 'powerpc's (wat dat ook moge zijn)' sinds Snow leopard niet langer worden ondersteund.
Mijn imac is een ouder model, dus ik dacht dat ik wel goed zat... maar hij is kennelijk optijd met zijn updates want momenteel zit er High Sierra op als besturingssysteem. Toevallig heb ik nog een oude macbook liggen waarvan ik weet dat die nog wel Snow Leopard draait, maar deze is een jaar geleden op een grijs scherm gegaan en daar issie nog steeds (oplossing voor dat probleem zijn trouwens ook welkom). De verzameling aan Mac's heb ik via mijn ouders, deze zijn 'oud/over' vanuit het bedrijf. De imac is eigenlijk ter tijdelijke vervanging van de macbook.

Wat heb ik geprobeerd:
- Ik heb mijn macbook via zo'n Thunderkabel aan de imac gehangen en de disc in de laptop gedaan. Daar trapte de imac niet in, helaas. Gelukkig kreeg ik de disc nog wel terug.
- Ik heb Virtualbox gedownload. Dat was ook al een avondtuur opzich, maar het programma zelf ziet er makkelijk genoeg uit.

Waarom post ik hier dan iets?
Ik heb heel braaf alle stappen gevolgd om een VM Snow leopard aan te maken. Maar als ik hem dan aanzet dan krijg ik een zwart MSDOS (ik weet het, zo heet het niet maar daar lijkt het op) beeld en een melding over UEFI interactive shell v2.2 en nog wat codes eronder.

En daar heb ik het opgegeven. Ik heb geen flauw idee hoe verder. Ik heb gegoogled en kwam een paar dingen tegen, iets met de EFI knop aan en uitzetten in Virtualbox maar dat werkte ook niet.

De paar dingen die ik kon vinden (oa in de handleiding van Virtualbox) snapte ik niet, want zoals gezegd, ik ben een leek.

Ik wil gewoon een spelletje spelen. Ik heb braaf alleen maar Mac producten en speciaal het Macspel gekocht want downloaden is niet oke (en ik snap het niet), maar ik vind het toch wel erg jammer en mega frustrerend dat het niet werkt.



Optie 2 is trouwens High Sierra downgraden, internet zei dat dit heel makkelijk ging met een paar toetsencombo's, maar ik vind het best een heftige procedure en weet niet wat de consequenties ervan zijn.


Dus: Wie kan mij helpen zodat ik op een of andere manier mn spelletje kan spelen?

Alvast bedankt!



Offtopic: Ik heb mijzelf pas net geregistreerd en ik heb een beetje gekeken naar gelijke topics, maar die zijn allemaal net iets anders dus dan snap ik er nogsteeds niks van.
Als dit topic verkeerd staat, sorry.
geplaatst door: Ilse_123
antw: VM Snow Leopard gebruiken op High Sierra
reactie #1 geplaatst: 26 maart 2020 - 17:12
Hoi Ilse,

Welkom op dit forum!

Eerst moet ik even technisch worden.

OS X 10.5 (Leopard) is de laatste Power PC (PPC) versie van het besturingssysteem.
OS X 10.6 (Snow Leopard) is de eerste versie van het besturingssysteem welke alleen op Intel draait, en het is de laatste versie die Rosetta draait, en Rosetta maakt het mogelijk om PPC software op een Intel computer te draaien.

Er kan alleen wel een addertje onder het gras zitten...

Voor OS X 10.x had je system / Mac OS versies tot en met 9, wat sinds OS X (de oude naam van macOS) "Classic" heet.


Onder Snow Leopard kun je alleen OS X PPC programma's draaien.

Als jouw spelletje nog ouder is, als het gemaakt is voor een Classic Mac OS, dan is OS X 10.4 de laatste versie waar je spelletje op gaat draaien, dan hoef je al die moeite niet te doen.

Wat zijn de voorwaarden voor dat spelletje, voor welke versie van (Mac) OS (X) is het gemaakt?
geplaatst door: MacFrankie
Op mijn werk heb ik al Windows, thuis wil ik geen systeembeheerder meer zijn!
antw: VM Snow Leopard gebruiken op High Sierra
reactie #2 geplaatst: 26 maart 2020 - 17:17
Hoi hoi!

Welkom hier.. Je hebt jezelf een aardig eind op weg ge-googled, maar wel een lastig probleem te pakken :wink:. 'Power PC' is de processor vóór de huidige Intel chips. Als het spel daarvoor geschreven is werkt het inderdaad niet op moderne Mac's. Je huidige Mac 'downgraden' zou ik zeker niet doen, op nieuwere Mac's kun je geen oude macOS versie zoals Snow Leopard zetten.

Blijft inderdaad de 'VM' methode over. Ik heb er hier een aantal draaien zoals Lion en El Capitan. Maar juist Snow Leopard is lastiger, ik heb alleen ervaring met Parallels en daar kan het sowieso niet (eventueel wel de server versie). Theoretisch zou het in VirtualBox inderdaad moeten kunnen, ik vraag me af (als het lukt) of dat nog een acceptabel resultaat geeft qua snelheid. En dan lees ik in dit draadje ook nog: "Apparently this title can't run in emulation because it requires 3d Open GL graphics."

Eerlijk gezegd lijkt het me erg lastig om dit voor elkaar te krijgen, en misschien zelfs onmogelijk. De Mac versie van het spel is inmiddels 17 jaar oud...

Oeps: MacFrankie is me voor en zegt ook zinnige dingen, ik laat dit toch maar staan. Meerdere inzichten kan geen kwaad :wink:. Ik dacht dat Zoo Tycoon voor OSX PPC geschikt was?
geplaatst door: boiing
Op zoek naar een oudere Mac mini? Zie rubriek 'Tweedehands aangeboden'.
antw: VM Snow Leopard gebruiken op High Sierra
reactie #3 geplaatst: 26 maart 2020 - 17:25
Allereerst alvast bedankt voor de snelle reactie's.

Op het spelletje staat:
Mac OS X 10.2.8 or later - Mac Power PC G3/G4/G5 en dan nog wat geneuzel over vrije ruimte en RAM .

Als ik het zo lees vrees ik dat ik een beetje pech ga hebben. Ondertussen ook de laptops van de buren erbij gepakt... Mojave en El Capitan dus dat wordt ook niks.
geplaatst door: Ilse_123
antw: VM Snow Leopard gebruiken op High Sierra
reactie #4 geplaatst: 26 maart 2020 - 17:28
Mojave en El Capitan dus dat wordt ook niks.

Nee, dat werkt ook niet. Eventueel is dit een idee, daar kun je wel Snow Leopard op draaien :sneaky2::

https://www.marktplaats.nl/a/computers-en-software/desktops-apple/m1526806952-imac-2006-wit.html

Ook nog wel een 'dingetje' om SL erop te krijgen als het er niet op staat, maar dat lukt wel met wat hulp op dit forum. En let op het minimum RAM, deze heeft maar 2GB, er staan er meer op Marktplaats mocht je het serieus overwegen.
geplaatst door: boiing
Op zoek naar een oudere Mac mini? Zie rubriek 'Tweedehands aangeboden'.
antw: VM Snow Leopard gebruiken op High Sierra
reactie #5 geplaatst: 26 maart 2020 - 17:32
Ik zal ook op het bedrijf eens kijken wat ze stiekem op zolder nog verstopt hebben liggen :hypocrite:

Bedankt allemaal, jullie hebben mij een avondje gefrustreerd googlen en schelden naar mijn imac bespaard!

geplaatst door: Ilse_123
antw: VM Snow Leopard gebruiken op High Sierra
reactie #6 geplaatst: 26 maart 2020 - 17:46
Dat is zonde ja, schelden op je iMac :biggrin:. Een makkelijkere manier zou trouwens zijn om een Windows VM op je Mac te zetten en de Windows versie van Zoo Tycoon te spelen. Ook dat heeft misschien zijn 'issues' trouwens (zie het draadje hieronder), maar wel iets meer kans op succes. Het ligt een beetje aan je hardware of het acceptabel is qua snelheid.

https://forums.virtualbox.org/viewtopic.php?f=1&t=92955
geplaatst door: boiing
Op zoek naar een oudere Mac mini? Zie rubriek 'Tweedehands aangeboden'.
antw: VM Snow Leopard gebruiken op High Sierra
reactie #7 geplaatst: 26 maart 2020 - 18:00
Allereerst alvast bedankt voor de snelle reactie's.

Op het spelletje staat:
Mac OS X 10.2.8 or later - Mac Power PC G3/G4/G5 en dan nog wat geneuzel over vrije ruimte en RAM .
Knip
Je kunt vanalles gaan proberen maar dit zal never nooit niet draaien op de intel apple. De power PC spelen (g3, g4 en g5) zullen nooit draaien ook al neem je een oudere mac die nog wel 10.5 draaien. Het aansturen van de hardware die het spel gebruikt is er gewoon niet.
Er is een optie op virueel een power pc te emuleren maar om dit allemaal te proberen en werkzaam te maken is een mooi streven maar is geen garantie dat je spel ook virtueel zal werken. Nogmaals als je spel g4 en g5 nodig hebben stop dan maar met proberen. Ik zou als ik dit spel zou willen spelen een g5 aanschaffen die heb je al voor? 35€ en dan werkt het wel.
geplaatst door: pjottervmr
geplaatst door: penseel
Het blijft een gedoe met die computers!
antw: VM Snow Leopard gebruiken op High Sierra
reactie #9 geplaatst: 26 maart 2020 - 20:18
Powermac,   https://www.marktplaats.nl/l/computers-en-software/desktops-apple/f/powermac/2337/
Zo dat zijn stevige prijzen......
Geloof me een g5 tower met HD, geheugen? 2 gb? en alles werkend voor 35 is geen probleem :-)
geplaatst door: pjottervmr
geplaatst door: Mac OS X
mvg Mac OS X, Mac gebruiker vanaf 2014 / 2x iBook G4 (2004) 1x iBook G3 (2001) RIP 1x iPod 1x iMac 27 5K (2017) 1x iPhone 7 128GB 2016 1x Apple SuperDrive
old Apple computers never death
antw: VM Snow Leopard gebruiken op High Sierra
reactie #11 geplaatst: 26 maart 2020 - 20:48
Heb je nog een iPad rondslingeren? In dat geval zou ik gewoon deze downloaden:

https://apps.apple.com/us/app/animal-park-tycoon-deluxe/id979953503
geplaatst door: Raf
Switcher sinds 07/2003
antw: VM Snow Leopard gebruiken op High Sierra
reactie #13 geplaatst: 26 maart 2020 - 20:56
Je kunt vanalles gaan proberen maar dit zal never nooit niet draaien op de intel apple. De power PC spelen (g3, g4 en g5) zullen nooit draaien ook al neem je een oudere mac die nog wel 10.5 draaien. Het aansturen van de hardware die het spel gebruikt is er gewoon niet.

@pjottervmr, even ter leering ende vermaeck: Snow Leopard met Rosetta draait wél Power PC programma's. Niet G3/G4/G5 maar @Ilse_123 zegt dat dit op de doos staat:

"Mac OS X 10.2.8 or later - Mac Power PC G3/G4/G5", dat streepje ertussen geeft twee mogelijkheden aan. Het zou op een Intel iMac met Snow Leopard en Rosetta gewoon moeten werken.
Laatst bewerkt op: 26 maart 2020 - 21:09 door boiing
geplaatst door: boiing
Op zoek naar een oudere Mac mini? Zie rubriek 'Tweedehands aangeboden'.
antw: VM Snow Leopard gebruiken op High Sierra
reactie #14 geplaatst: 26 maart 2020 - 21:37
Je zou hier nog eens kunnen kijken...
geplaatst door: MacFrankie
Op mijn werk heb ik al Windows, thuis wil ik geen systeembeheerder meer zijn!
antw: VM Snow Leopard gebruiken op High Sierra
reactie #15 geplaatst: 26 maart 2020 - 21:42
Je kunt vanalles gaan proberen maar dit zal never nooit niet draaien op de intel apple. De power PC spelen (g3, g4 en g5) zullen nooit draaien ook al neem je een oudere mac die nog wel 10.5 draaien. Het aansturen van de hardware die het spel gebruikt is er gewoon niet.
Daar zit je er helemaal naast! Hoe lang heb je al een Mac?

Ik heb op een PPC G4 Mac met OS X 10.4 erop Classic applicaties gedraaid.
Ik heb op een Intel Mac met OS X 10.6 erop OS X PPC applicaties gedraaid.

Het kan wel!
geplaatst door: MacFrankie
Op mijn werk heb ik al Windows, thuis wil ik geen systeembeheerder meer zijn!
antw: VM Snow Leopard gebruiken op High Sierra
reactie #16 geplaatst: 27 maart 2020 - 08:48
Daar zit je er helemaal naast! Hoe lang heb je al een Mac?
Knip
Vanaf 1985 🙂 en bijna elk model en software heb ik gebruikt draai nu gewoon nog vaak classic op de scheerspiegel
Laatst bewerkt op: 27 maart 2020 - 09:02 door pjottervmr
geplaatst door: pjottervmr
antw: VM Snow leopard gebruiken op High Sierra
reactie #17 geplaatst: 27 maart 2020 - 08:55
@pjottervmr, even ter leering ende vermaeck: Snow Leopard met Rosetta draait wél Power PC programma's. Niet G3/G4/G5 maar @Ilse_123 zegt dat dit op de doos staat:

"Mac OS X 10.2.8 or later - Mac Power PC G3/G4/G5", dat streepje ertussen geeft twee mogelijkheden aan. Het zou op een Intel iMac met Snow Leopard en Rosetta gewoon moeten werken.
Knip

Inderdaad te snel gelezen dacht een puur powerpc spel en dat werkt zeer slecht onder rosetta op de intel mac. Oudere powerpc programma,s hebben wel gedraaid maar was bij mij geen succes.
geplaatst door: pjottervmr
antw: VM Snow Leopard gebruiken op High Sierra
reactie #18 geplaatst: 27 maart 2020 - 09:01
Knip
Ik heb op een PPC G4 Mac met OS X 10.4 erop Classic applicaties gedraaid.
Ik heb op een Intel Mac met OS X 10.6 erop OS X PPC applicaties gedraaid.
Knip
Inderdaad, ik heb nog gewoon diverse g4’s met classic staan en diverse g5’s heb OSX ppc programma. Ik heb gewoon niet goed gelezen en gedacht aan classic op de powerpc.
geplaatst door: pjottervmr
antw: VM Snow Leopard gebruiken op High Sierra
reactie #19 geplaatst: 27 maart 2020 - 10:05
Gewoon een gedachte: Zoo Tycoon bestaat volgens mij tevens voor Windows. Mac is sinds 10.6 overgestapt op Intel Processors ... Dat betekend dat je in dit geval volgens mij met (bijvoorbeeld) Virtual Box Windows kunt installeren en gevirtualiseerd kunt draaien.

Virtualisatie is iets anders dan Emulatie. In gewone mensentaal: Virtualisatie heeft meestal betere perfomantie dan emulatie.

Onder Windows kun je een Windows versie van Zoo Tycoon installeren.

Voorbeelden die ik online ben tegengekomen:

https://www.ebay.com/itm/Zoo-Tycoon-Jewelcase-PC-CD-ROM/292849954718?hash=item442f37af9e:g:UaIAAOSwypZcB6ye

https://www.ebay.com/itm/Zoo-Tycoon-Microsoft-Game-Studios-Blue-Fang-PC-Big-Box-Windows-Complete-2001/283652465913?hash=item420b0124f9:g:620AAOSwD0ddsMvk

Het spel is ook op Steam te vinden, maar of de betreffende Mac krachtig genoeg is om het spel te spelen betwijfel ik ...

https://store.steampowered.com/app/613880/Zoo_Tycoon_Ultimate_Animal_Collection/

... daarom zou ik - als het perse op de Mac moet draaien, dan waarschijnlijk de Windows versie kiezen maar dan in een ge-emuleerde omgeving. Vroeger waren zeker de nodige Mac spelletjes te krijgen, en nog hele leuke ook. Maar vaak bestaan de softwarehuizen niet meer of zijn ze overgestapt op mobiele games ...

Overigens is het niet zo dat Windows 10 alle oude software probleemloos draait, immers ook de ontwikkeling op Windows 10 staat niet stil en dat betekend dat sinds Windows XP en Windows Vista er natuurlijk heel veel is veranderd. Op Windows 10 draait de software in een compatbiliteitsmodus. Maar er is toch best wel wat software (en dus ook spelletjes) die dan nog draaien. Kan het proberen waard zijn om het te proberen ...



geplaatst door: doctor_apple
antw: VM Snow Leopard gebruiken op High Sierra
reactie #20 geplaatst: 27 maart 2020 - 10:10
Gewoon een gedachte: Zoo Tycoon bestaat volgens mij tevens voor Windows. ... Onder Windows kun je een Windows versie van Zoo Tycoon installeren.

'Gewoon' een gedachte? Plagiaat! Dat is het.

Een makkelijkere manier zou trouwens zijn om een Windows VM op je Mac te zetten en de Windows versie van Zoo Tycoon te spelen.

 :tounge: :wink:
geplaatst door: boiing
Op zoek naar een oudere Mac mini? Zie rubriek 'Tweedehands aangeboden'.