Soms kom je er zelf niet meer uit, dan moet je hulp vragen van anderen om een probleem op te kunnen lossen.

Hier bij mij op de werkbank staat een iMac 27" van mid 2011. Deze had videokaart problemen, die zijn inmiddels opgelost. Nu blijft alleen de ODD ventilator op volle snelheid draaien, iets wat niet de bedoeling is wanneer de boel niet al te warm wordt.

Verschillende dingen zijn al geprobeerd waaronder:
* ODD temperatuursensor gewisseld
* Videokaart gewisseld
* Display gewisseld
* Logic Board gewisseld
* PRAM reset
* Andere harde schijf, en dus een andere installatie van macOS
* ODD ventilator gewisseld

Zoals op de schermafbeelding hieronder te zien is zijn er geen excessieve temperaturen die van invloed kunnen zijn op de ODD ventilator.
Schermafbeelding 2019-08-01 om 14.23.50.png[Opgelost] iMac 27" mid 2011 ODD fan blijft op volle snelheid draaien


Uiteraard kan ik, met mijn eigen schijf in deze iMac, de ventilator wel softwarematig stil laten zijn maar dat is uiteraard geen oplossing.

Wie-o-wie heeft nog een suggestie?
Laatst bewerkt op: 7 augustus 2019 - 10:58 door Sypie
geplaatst door: Sypie
Check sypie.nl voor eigenwijze reparatieblogs.
Sensor van het LCD paneel (achterkant scherm en connectie op moederbord) goed bekeken of doorgemeten?

https://blog.macsales.com/19617-diagnosing-2009-2010-imac-fan-speed-issues-after-upgrading-the-main-hard-drive/

De link gaat over een iets ouder model, maar het gaat om het feit dat een defecte LCD sensor ook de oorzaak kan zijn van de ODD fan die op hol slaat. En de 2011 iMac heeft ook ergens zo'n sensor zitten.
geplaatst door: boiing
Bedankt voor je suggestie.

De sensor op het scherm heb ik net bekeken. Daar mankeert niks aan. Dit is ook te zien aan de schermafbeelding waarin de temperaturen van het scherm staan.

De startpost is aangevuld met het feit dat het scherm ook gewisseld is. Ook dat bood geen oplossing.
geplaatst door: Sypie
Check sypie.nl voor eigenwijze reparatieblogs.
Mac uitzetten.
Stekker achteruit de Mac halen.
Een minuut wachten.
Stekker er weer in.
Opstarten.

Dat hielp bij mij. Er zit een of andere schakelaar in/achter de 230 v. ingang die getriggerd wordt als je de stekker eruit haalt.
geplaatst door: Alvinus
Bedankt voor je reactie.

Tussen het wisselen van de componenten heeft meerdere malen meer dan een minuut tijd gezeten. Ik mag toch hopen dat dit het zelfde effect heeft.
geplaatst door: Sypie
Check sypie.nl voor eigenwijze reparatieblogs.
Maar is de stekker een tijdje achteruit de iMac geweest bij een herstartprocedure? Je zult bij het opkalefateren van de betreffende iMac zeer waarschijnlijk de stekker hebben losgehad, maar toen lag de machine natuurlijk helemaal uit elkaar.
Ik vond het indertijd ook een beetje vreemd advies, naar ik meen uit de officiële Mac helphoek, maar het bleek wel de oplossing. Je kan het altijd proberen, kost niks.

Ik acht jouw kennis vele malen hoger dan de mijne, dus je kunt mijn gezeur verder ook negeren, hoor! Ik zag deze maatregel echter niet staan tussen die je opsomt.
geplaatst door: Alvinus
Sypie, je hebt werkelijk al zowat alles geprobeerd. Zelfs het moederbord gewisseld, zeg!

Heb je de fan zelf al eens gewisseld? Mss. zit daar een actief componentje op dat stuk is (een halfgeleider die kort ligt, bv). Long shot, ik weet het...

Heb je een service manual?
geplaatst door: HEXDIY
If it ain't broke, don't fix it!
Ik weet uit ervaring dat je hd een sensor heeft die dingen regelt, ook een fan.
Is dat al bekeken?

 :music:

Succes.

 :cool:

geplaatst door: VwVanFan
Met alle respect, ik denk dat Sypie die materie beter beheerst dan wij allemaal samen...
Hij specialiseert nl. in ± 2011 27" iMacs.
geplaatst door: HEXDIY
If it ain't broke, don't fix it!
@Alvinus: Gezeur is het niet. Het is een suggestie die ik morgen ga proberen. Soms kan een balletje raar rollen. Ik haal deze iMacs dan uit elkaar, wissel wat dingen om en dergelijke maar dat wil niet zeggen dat ik er alles van weet.

@De ventilator is inmiddels ook gewisseld (zal ik in de startpost er bij zetten). Ook dit was niet de oplossing.

@VwVanFan: In de 2011 modellen zit de sensor in de schijf zelf, waarbij de schijf ook nog eens aangepaste Apple firmware heeft. Op het moment dat je er een andere schijf in zet, zoals mijn test-SSD, gaat alleen de HDD ventilator op volle toeren draaien. De andere 2 ventilatoren worden daar niet door aangestuurd. In dit geval is de ODD (Optical Disk Drive - DVD-speler dus) ventilator hyperactief zonder dat ik daar een geldige reden voor kan vinden.

@HEXDIY: Specialiseren is een groot woord. Ik repareer wel eens wat, uiteindelijk moet mijn motor ook blijven rijden. Uiteraard sta ik open voor alle suggesties die anderen kunnen bedenken, ik heb ook zeker niet alle wijsheid in pacht.
geplaatst door: Sypie
Check sypie.nl voor eigenwijze reparatieblogs.
Citaat
De ventilator is inmiddels ook gewisseld (zal ik in de startpost er bij zetten). Ook dit was niet de oplossing.

Verdraaid Sypie, ik had nog zo gehoopt...
Dit was het laatste onderdeel dat je nog niet had gewisseld.

Voor jouw laatste post had ik nog deze ingeving: mogelijk is de zgn. "tacho terugmelder" in je ventilator stuk. Of diens vebinding met het MoBo onderbroken.

Bij de meeste ventilatoren verloopt de tacho terugmelding via het gele kabeltje. Is dat onderbroken of stuk, kan zoiets veel amok veroorzaken.

Maar ja, na 2 ventilatoren en 2 moederborden gaat deze theorie natuurlijk niet meer op.

Laatste test die ik kan bedenken: je stuurde ons enkel een readout van de temperaturen, en summiere RPM gegevens, uitgelezen door 1 enkel progje.
Kan je ons ook een readout van de toerentallen van alle ventilatoren bezorgen via een ander progje?
Bv. via iStat Pro?

Als die readout al te laag of op 0 ligt, met de temperatuurgegevens en auditieve ervaringen die je ons reeds stuurde is er duidelijk iets mis met de tacho terugmelding van de ODD ventilator, zijnde: tacho terugmelder zelf, diens kabel, of diens verbinding met het MoBo.
Stuurelectronica zelf valt uit te sluiten wegens test met een alternatief MoBo.

Verdraaid, wat een raadsel zeg!

Ik ben een hardware mens; dit begint echter meer en meer naar software te ruiken.
En het probleem treedt blijkbaar ook op als je van een extern systeem opstart?

Nou Moe!
geplaatst door: HEXDIY
If it ain't broke, don't fix it!
En nog wat, mogelijke workaround:
zou het wat zijn om een NTC weerstand  in serie te zetten met de voedingslijn van die ventilator?

Een NTC-weerstand is een weerstand met een negatieve temperatuurcoëfficiënt. Dit betekent dat de elektrische weerstand afneemt als de temperatuur toeneemt.

https://nl.wikipedia.org/wiki/NTC-weerstand
geplaatst door: HEXDIY
If it ain't broke, don't fix it!
Bij de meeste ventilatoren verloopt de tacho terugmelding via het gele kabeltje.

Ventilatoren in een iMac hebben slechts 4 zwarte draadjes. Het is geen PC, waar je een molex connector hebt met verschillende kleuren. ;-)

Kan je ons ook een readout van de toerentallen van alle ventilatoren bezorgen via een ander progje?
Bv. via iStat Pro?

Dat kan ik doen. Zodra ik mijn eigen Test-SSD weer aansluit kan ik doen en laten met die iMac wat ik wil.

En het probleem treedt blijkbaar ook op als je van een extern systeem opstart?

Ja. Dat is ook het gekke er aan. En mijn Test-SSD is een goed werkend systeem wat al in diverse Macs heeft gezeten.

Nou Moe!

Dat ga je vanzelf worden wanneer je alles moet proberen om dit op te lossen.

@martijnvantillo: Die ga ik ook doen. Dank voor de tip.
geplaatst door: Sypie
Check sypie.nl voor eigenwijze reparatieblogs.
Vreemd hoor! Maar let eens op: je PSU secundary heatsink is heet. Wat heeft de ODD fan daarmee te maken?

Citaat
Ventilatoren in een iMac hebben slechts 4 zwarte draadjes. Het is geen PC, waar je een molex connector hebt met verschillende kleuren. ;-)

Daar was ik ondertussen ook al achter. Ik zat met de ventilator van een defecte videobeamer in mijn hoofd. :wacko:
geplaatst door: HEXDIY
If it ain't broke, don't fix it!
Aht ?

https://www.techrepublic.com/article/how-to-decipher-error-codes-in-apple-hardware-test-or-apple-diagnostics/

Deze gedaan en inderdaad kwam er een melding uit.

De melding die verschijnt is deze:
Citaat
4sns/1/C0000008: TS0p --124

Daar gaan we morgen eens even mee aan het stoeien. Ik heb in ieder geval gelezen dat het te fixen is.
geplaatst door: Sypie
Check sypie.nl voor eigenwijze reparatieblogs.
Ondertussen heeft een mac guru me ingefluisterd dat de tacho terugmelder van veel Mac ventilators een Hall sensor is. Vandaar wellicht de 2 extra aansluitingen (apart van stomme + en - voeding)

Ziehier wat Mayer van iFixit daarover te vertellen heeft:

Citaat
I've had to replace the optical drive fan in several of these. Some of the fans can be fixed by simply pushing on the center of the fan to move it back in place.

Bron:
https://www.ifixit.com/Answers/View/224367/Fans+Noise,+Error:+4SNS-1-C0000008:TS0P--124

https://nl.wikipedia.org/wiki/Hall-sensor

Of zoals steeds, in meer detail: de Engelstalige WiKi:

https://en.wikipedia.org/wiki/Hall_effect_sensor

Makes sense: komt de ene helft van de Hall sensor (op de rotor van je ventilator) nét iets verder te liggen van de andere helft van die Hall sensor (op de stator van die ventilator), zou het best wel eens kunnen dat diens stroompje/meetwaarden buiten de waarden van je regelcircuit komen te liggen.

Bij verouderde ventilators is het erg plausibel dat er wat axiale speling optreedt in de ventilator, waardoor diens rotor en stator wat meer uit elkaar komen te liggen.
Met als gevolg dat de Hall sensor/ dynamo niet genoeg stroom meer opwekt.

De "gezond verstand" methode van Mayer (het terug bij mekaar brengen van rotor & stator) zorgt er wellicht voor dat die Hall sensor weer op het niveau van het regelcircuit zit.

Enfin, mogelijk klets ik uit mijn nek, maar het is snel genoeg te proberen hee.
Korte samenvatting: geef die ventilator eens een stevige kneep op zijn rollager!

Het regelcircuit kan ook naar de vaantjes zijn, maar door het proberen met een ander moederbord lijkt me die kans vrij klein.

Succes!
geplaatst door: HEXDIY
If it ain't broke, don't fix it!
Bij het verder zoeken naar oplossingen kwam ik steeds oplossingen tegen die met MacBooks te maken hadden. Hierbij werd vaak iets over temperatuursensoren gezegd anders dan de ODD temperatuursensor.

Dus, even grabbelen in mijn doos met onderdelen en daar een temperatuursensor gevonden die naast de iSight camera geplakt zit. Deze temperatuursensor meet de warmte van de behuizing en dus de omgevingstemperatuur ook.

De sensoren heb ik eerst doorgemeten op weerstand. Alle sensoren zitten zo rond de 30M Ohm. Ook de betreffende sensor. Maar ja, je weet maar nooit.

Na de sensor afgekoppeld te hebben en een losse even tijdelijk aangesloten te hebben bleef de iMac heerlijk stil. Het lag dus aan een sensor waar ik het niet gezocht had.

Dit verklaart ook waarom het met het uitwisselen van de andere onderdelen steeds zo bleef.

Gelukkig is deze weer klaar, ik moet ruimte hebben op mijn werkbank...

Iedereen bedankt voor het meedenken.
geplaatst door: Sypie
Check sypie.nl voor eigenwijze reparatieblogs.