
            
          

            
              
       

             
        

             

   

       
         

           
        

   
              

               
               

           

  
           

              
            

    

             
      

Find Your Files 
When we think of file management, it’s usually focused on the front 
end of dealing with files: organizing how and where they’re stored, 
adding metadata like tags to better identify them, and setting up ways 
to make the process easier. Once a file has been handled, we move on 
to the next, and then to the next. 

That work is all to service the other side of file management: finding 
those files later, whether that means knowing immediately which 
directory to open or using search tools to get software to do the work 
for you. 

Find Files in macOS
 

Apple’s Spotlight search technology is woven throughout macOS, 
collecting results from your web browsing history, contacts, calendar 
events, and several other sources. For our purposes, of course, I’m 
focusing on locating files and folders in the Finder. 

Filter Files by Tag 
I’m getting this one out of the way early because it’s quick and easy. 
Expand the Tags list in the sidebar of a Finder window and select a tag 
to view only files marked with that tag. You can select only one tag at a 
time, though, so if you need a more complicated search, keep reading. 

Perform Spotlight Searches 
Most often, you’ll probably want to bring up the Spotlight window, 
which can be invoked in any app, not just the Finder. It’s a good first 
step, and you can refine the search if needed. To perform a general 
Spotlight search, do the following: 

1. Click the Spotlight icon in the menu bar, or press ⌘-Space, to 
bring up the Spotlight window (Figure 55). 
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Figure 55: The Spotlight Search bar is a fine place to begin. 

2.	 Type anything in the field; results appear as you type, even filling in 
words that macOS thinks you might be looking for based on recent 
items (Figure 56). 

Figure 56: I’ve typed only “rocket” so far, but Spotlight has sug-
gested the Rocketeering 101 folder as the top pick because it has 
been recently modified. 

3.	 Use the arrow keys or single-click other items in the list to select 
them, or scroll to view more. 

4.	 With a selection made, press Return or double-click the item to 
open it and exit the search bar. 

Tip: Press the Tab key to display a preview of the selected item in 
the search results window. Hold the ⌘ key to see the item’s path at 
the bottom of the preview (Figure 57). 

94 



        
  

               
        

     
          

    
    

         
    

         
  

   

           
     

Figure 57: Pressing the Tab key gives you a preview while still in 
the floating Spotlight Search window. 

If you want to refine the results, scroll to the bottom of the list and 
choose Search in Finder, where you can apply additional criteria. 

What Else Can a Spotlight Search Do? 
The Spotlight Search bar can also perform some nifty actions, such as 
converting numbers, doing mathematical calculations, looking up the 
definition of a word, and launching apps. 

To give you an idea, press ⌘-Space and type 6.25m. It assumes you 
mean “6.25 meters,” and displays 6.25m = 6.84 yards. Press the Tab 
key to view other conversions, such as 246.06 inches. You can 
convert weights and volumes (3 tbsp = 9 teaspoons), temperature 
(46F = 7.78 °C), currency (27 euros = 32.72 US dollars), and more. 

When you need to make a quick calculation, just type it into the field, 
such as 674*37, and see that the answer is 24,938. 
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Search in the Finder 
The Spotlight window is the quickest way to perform a search for a 
wide range of items, but when you’re specifically looking for files and 
folders, it’s best done using the Spotlight field in a Finder window: 

1. Open a new Finder window. 

2. Click the Spotlight icon in the window’s toolbar, or press
 
⌘-Option-F to activate the Search field.
 

3.	 Start typing a search term into the field. The window displays 
matches as you type (Figure 58). Put words that belong together in 
quotes, as in "rocket booster". 

Figure 58: Possible matches appear in the window as you type. In 
this case, the query has found 324 items that include “rocket” in the 
filename or in the contents of the files. (If you don’t see the item 
count, choose View > Show Status Bar.) 

Note: When you perform a search in a Finder window, think of the 
previous contents as waiting patiently under the search interface. 
When you end the search by clicking the Cancel icon, the previous 
window contents reappear. 

The advantage of searching in a Finder window versus the Spotlight 
window is the additional controls available to direct your query. In 
Figure 58, you can see the option in the pop-up menu to narrow the 
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search to files with “rocket” in the filenames or to show only files 
marked with the “rocketeering101” tag, plus the option to search This 
Mac (the entire computer) or just the contents of the window in which 
you began the search, in this case my home folder “jeffcarlson.” 

Tip: You can set the default location for Finder window searches. Go 
to Finder > Preferences > Advanced and choose an option from the 
“When performing a search” pop-up menu: Search This Mac, Search 
the Current Folder, or Use the Previous Search Scope. 

Use Modifiers in the Search Field 
There are two ways to boost the effectiveness of a Spotlight search: 
using text modifiers when typing the search term, and defining addi-
tional criteria using a series of pop-up menus. The first option is the 
quickest to implement because you’re already typing, though you have 
to know what to enter; the second option involves more work, but can 
dig further into the nooks of your files and folders to find results. 

In the Search field (and also in the Spotlight window), type not just the 
term you’re looking for, but information about the term. For instance, 
the term “rocket” alone brings up hundreds of files on my Mac that 
either include “rocket” in their filename, contents, tags, or other 
metadata. 

But let’s say we want only image files related to rockets. For that, we’d 
type rocket kind:image. The results include images from our imaginary 
school project and a few others, for a total of 10 files (Figure 59). 
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Figure 59: By typing a few more characters, I’ve narrowed the 
results to include only images relating to “rocket.” 

Although we can see the files we want in this list, suppose we want to 
narrow it to files created in December. We’d type rocket kind:image 
created:>=12/1/20, which is shorthand for “files containing the word 
‘rocket,’ which are image files, and created on or after December 1, 
2020” (Figure 60). (Note that there are no spaces within each at-
tribute; spaces are used only to separate them.) 

Figure 60: Now we see only the four image files containing “rocket” 
and created in December 2020. 

The Search field also understands the Boolean operators AND, OR, 
and NOT. Instead of Spotlight trying to find files that match every 
condition in the field, the operators give you power to exclude or offer 
alternatives. For example, imagine we want to find every file that 
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matches “rocket,” but we don’t need any of the image files for this 
search. We’d write rocket NOT kind:image (Figure 61). 

Figure 61: Adding NOT removes image files from the results. 

Tip: The capitalization of the Boolean operator is important, as it 
signals Spotlight to treat it different from regular words. 

For another example, "rocket booster" AND jetpack NOT kind:image 
reveals files with both the terms “rocket booster” and “jetpack,” but 
which are not images. You can substitute a minus sign (hyphen) for 
NOT, as in "rocket booster" AND jetpack -kind:image. 

Add Search Criteria 
Boolean operators and modifiers are certainly convenient. However, 
this approach annoys me somewhat because you need to have these 
descriptors in your head already. (To be fair, in most cases you can 
make educated guesses and hit the mark, such as kind:pdf or 
modified:<12/9/20.) 

That’s why the capability to define all sorts of search criteria in a 
Finder window is so powerful. You can find items using sets of criteria 
in fields and menus, laid out in front of you, so you don’t have to shake 
your memory for the correct terminology. Here’s how to access these 
controls: 

1. After you initiate a search, click the Add button at the right side 
of the window below the search field, which adds a new criterion to 
the top of the window. 
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2.	 From the first pop-up menu, choose which attribute to search, such 
as Name, Tags, or Kind. 

3.	 The context of the attribute determines the next options. For in-
stance, the default options for [Last modified date] look for match-
es within the last number of days (Figure 62). You can change the 
scope using the pop-up menus and number field to read [Last 
modified date] [is after] a specific date. 

Figure 62: Choose several date ranges to filter the results. 

4. To add more criteria, click the Add button for the item you just 
created; the new criterion appears below it. 

The search results update as you specify criteria. 

Where this approach gets really interesting is in the wide variety of 
attributes you can search for. Click the Add button and choose 
Other from the first pop-up menu. That displays a dialog containing 
hundreds of other criteria (Figure 63). 
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Figure 63: Search files based on hundreds of criteria. 

For example, if you wanted to find placeholder images in your project 
in order to replace them with better quality ones, you could add the 
attribute [Pixel width] and set it to [is less than] 1000. 

If you find yourself using one of these “other” attributes frequently, 
select the In Menu checkbox to add it to the first pop-up menu that 
appears when you add a new criterion. 

Lastly, we come to Spotlight’s secret weapon in Finder window search-
es. I mentioned earlier that you can use the Boolean operators AND, 
OR, and NOT when doing a text search. You can do the same in the 
criteria menus. 

The way the menus are constructed, the criteria fall under the “all” 
umbrella, where a file must match every item to show up in the search. 
For example, Spotlight would find files that include the word “rocket,” 
and were modified after 12/1/2020, and include the tag “jetpack.” If 
just one of those three attributes don’t apply, a file doesn’t appear in 
the results. 
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But what if you’re working on two rocket projects, one for school and 
one for your personal use? The query above would collect files for both 
projects. Using the Boolean option, you can make the query selective: 

1. Hold Option and click the More button that appears in place of 
the Add button. A pair of criteria are added: the Boolean opera-
tor on one line, and a regular criterion on a second, indented line. 

2.	 Set an operator from the first item: Any, All, or None (which corre-
spond to OR, AND, and NOT). 

3. Set the attribute for the second item. 

For our example, we’d set the Boolean operator to None, and the 
attribute to [Tags] [matches] rocketeering101 (the class name) 
(Figure 64). 

Figure 64: By omitting the “rocketeering101” tag with a Boolean 
operator of None, the files for this amazing—explosive, I dare say— 
business idea is kept separate from the jetpack school work. 
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Cut the Spotlight Clutter 
A spotlight is supposed to shine a narrow band of light on something 
to be highlighted, but over time Spotlight has become more of a 
floodlight. When you perform a Spotlight search, you get results that 
include events, theatrical movies, music artists, and Siri suggestions. 

Here’s how to be more choosy about what ends up in the results list. 
Go to Apple  > System Preferences > Spotlight and make changes 
on the following two tabs: 

✦	 Search Results: Deselect the checkbox for any categories you 
want to remove from search results, such as Bookmarks & History. 

✦ Privacy: Spotlight builds an index of your internal storage and 
any connected drives. To prevent it from indexing a location, click 
the Add button and choose a folder or volume Spotlight should 
skip. Or, drag the item into the privacy list. If you have a cloned 
drive attached to your computer for duplicate backups, you may 
want to add that to the list and avoid duplicate results in different 
locations. 

Create Smart Folders for Frequent 
Searches 
Building an elaborate search in the Finder seems like a lot of work each 
time you want to find something, but that effort doesn’t have to be 
tossed once you get the results. You can save the entire query as a 
smart folder, or create a smart folder from scratch, that performs the 
search whenever you load the folder. (If you’re familiar with smart 
albums in the Photos app or smart playlists in the Music or iTunes 
apps, it’s the same concept.) 

Using the example in Figure 64, where you have two separate but 
similar projects, it’s inevitable that more files will be added that fit the 
same criteria. Saving that search as a smart folder gives you the ease of 
opening a folder to reveal the files, instead of re-running the search, 
and the knowledge that the contents will be automatically updated to 
reflect any new or changed files that fit the criteria. 
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If you’ve decided to Organize Using Tags, or chosen to integrate tags 
more into your organizational system, smart folders really make that 
decision pay off. In the sidebar of Finder windows, you can select a tag 
in the Tags list, but only one tag at a time. A smart folder lets you save 
queries that include multiple tags. 

Create a Smart Folder 
There are two ways to create a smart folder: start one from scratch, or 
save the criteria from a current search. For the former, in the Finder 
choose File > New Smart Folder and add criteria as you did above in 
Add Search Criteria. In both cases, follow the next steps to save the 
search as a smart folder: 

1.	 Click the Save button below the search field. 

2.	 In the dialog that appears, give the smart folder (which has the 
filename extension .savedSearch if you’ve have all filenames visible) 
a unique name (Figure 65). 

Figure 65: Save the search query as a smart folder. 

3.	 Select the Add To Sidebar option to include the smart folder in the 
list of favorites for quick access. 
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4.	 Optionally choose a location for the smart folder (especially if you 
choose not to add it to the sidebar). The default location for them is 
~/Library/Saved Searches/, which isn’t normally accessible to 
browsing (see the sidebar just ahead, Reveal the Hidden Library 
Folder). 

5.	 Click Save. 

Note: If you’ve enabled syncing the Desktop and Documents folders 
in iCloud Drive (see Sync the macOS Desktop and Documents with 
iCloud), smart folders appear in the iCloud section of the sidebar. 

To access the smart folder later, select it in the sidebar (if you saved it 
there), or open it as you would any other folder in the Finder, such as 
by double-clicking it. Smart folders appear colored purple with a gear 
icon to differentiate them from other folders (Figure 66). 

Figure 66: I’ve saved this smart folder to the desktop. It also 
appears in the sidebar because I selected Add To Sidebar when 
creating it. 
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Reveal the Hidden Library Folder 
macOS and apps store a lot of important information in your 
~/Library folder—often stuff you don’t need to touch, but occasion-
ally want to access (like smart folders). If you open your home folder, 
however, you probably don’t see a Library folder. 

Precisely because apps use this folder as a place to store preferences 
and other files, Apple discourages folks from poking around inside 
(that’s also why the System folder is now read-only). It can be 
helpful to get into the ~/Library folder, though, so there are two 
ways to do it: 

✦ Hold Option and choose Go > Library, which is visible only when 
with the Option key modifier. 

✦ With a new Finder window active, choose Go > Home. Then 
choose View > Show View Options and select the Show Library 
Folder checkbox. 

If you do keep it visible, just promise not to start throwing away
 

random files.
 

Edit an Existing Smart Folder 
A smart folder is endlessly malleable, so if you want to add or remove 
search criteria, you can do it easily. Here’s how: 

1. Open a smart folder to view its results. 

2. Click the Action icon and choose Show Search Criteria. 

3. Change the criteria as needed to update the search results. 

4. Click the Save button. 

To remove a smart folder you’re no longer using from the sidebar of 
Finder windows, right-click (or Control-click) it and choose Remove 
from Sidebar, or drag it out of the window until the Remove icon 
appears on the pointer. 
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The smart album itself is still available where you saved it. If you want 
to delete it entirely, do the following: 

1.	 Locate the smart folder in the Finder. If it’s in the Finder window 
sidebar, right-click it and choose Show Enclosing Folder. Or, if it 
was saved in the default location, go to ~/Library/Saved Searches. 

2.	 Drag the smart folder to the Trash, or select it and choose File > 
Move to Trash. 

Because a smart folder is just a search query, none of the actual files 
and folders that appear in it are sent to the Trash. 

Perform a Siri Search 
Even when I’m working alone in my office, I’m not inclined to ask Siri 
to search for files for me. Plus, the accuracy depends entirely on how 
well Siri understands the request. That said, if you’re more chatty than 
I am, you may find it useful. To search for files using Siri, do this: 

1. Click the Siri app in the Dock, the Siri icon in the menubar, 
or say, “Hey Siri” (although the latter may be picked up instead by 
an iPhone or other Apple device nearby). If you own a MacBook Pro 
with a Touch Bar, touch the Siri icon there. 

2.	 Speak your search phrase, such as “Show me all image files tagged 
with rocket.” The text is dictated in the Siri window. 

3.	 Sometimes Siri will start the search when you stop speaking; more 
often, I find that I need to press the Siri icon again, click the 
active Siri icon in the Siri window, or press the Esc key, to complete 
the query. If results are found, they appear in the window (Figure 
67). 
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Figure 67: Invoking Siri brings up the familiar listening window 
(left). In the results window (right), you can see at the top where it 
initially didn’t transcribe my request correctly. 

4.	 Click one of the results to open a specific file or folder, or choose 
“Show all number results in Finder” to view them in one window. 
(As of Big Sur 11.1, this should work, but it appears to be buggy.) 

Spotlight Problems? Rebuild the Index 
Spotlight’s search is based on an index of everything it finds on your 
Mac, from file names and tags to contents. If results aren’t coming up 
as you expect, there’s a last-ditch solution: rebuild the index. To do 
so, follow these steps: 

1. Go to Apple  > System Preferences > Spotlight > Privacy. 

2. Click the Add button and choose the volume or folder that’s 
giving you trouble to the Privacy list. 

3. Select that item in the list and click the Remove button. 

4. Quit System Preferences. 

Spotlight rebuilds its index in the background, which takes a while. 
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