Kan je een userprofile repareren?
geplaatst: 11 augustus 2019 - 12:08
Ik heb een 2009 27" iMac waarop 4 userprofielen actief zijn: twee als admin en 2 als normale profielen.
Gisteravond bleef mijn iMac bij het afsluiten vasthangen op Mail en na lang wachten sloot hij alsnog normaal af.
Vanochtend wil ik inloggen en na 1 seconde blijft het witte ronddraaicirkeltje (wat aangeeft dat het userprofile wordt opgestart), stilstaan en dat blijft zo.
(Dus de iMac start succesvol op, maar hij blijft direct hangen op het opstarten van mijn useraccount.)
Hierna heb ik ingelogd op het andere account met adminrechten en dat functioneert prima. Van daaruit heb ik een schijf-EHBO opgestart op de SSD en ook dat verloopt prima zonder foutmeldingen.
Daarbij zie ik terloops dat ik al 7 snapshots heb.

Ik wil graag mijn eigen useraccount weer kunnen gebruiken.
Hoe krijg ik dat voor elkaar?

Update:
na een uur wachten logt e.e.a. weer verder dóór en staat mijn account er weer zoals altijd.
Ik heb geen idee wat de oorzaak is geweest.
Wat zou ik nu eerst moeten controleren?
Laatst bewerkt op: 11 augustus 2019 - 12:12 door Heintje
geplaatst door: Heintje
antw: Kan je een userprofile repareren?
reactie #1 geplaatst: 11 augustus 2019 - 12:16
Gebruik je FileVault?
geplaatst door: boiing
antw: Kan je een userprofile repareren?
reactie #2 geplaatst: 11 augustus 2019 - 12:37
Probeer eens in te loggen na het opstarten in Safe Mode/Veilige Modus.
Lukt dat wel?
geplaatst door: PS-MacGek
MacBook Pro Retina 15" (Late 2013), Mac Mini (2012), Mac Pro (2008), iPhone 5s
Avatar made by Dale Humphries
antw: Kan je een userprofile repareren?
reactie #3 geplaatst: 11 augustus 2019 - 14:00
Inmiddels zit ik weer in mijn normale profile en ik log zo lang mogelijk niet uit.
De vraag is dus eigenlijk: wat moet ik doen om te zorgen dat het niet nogmaals gebeurt?

FileVault gebruik ik niet, alles staat onversleuteld gewoon op de SSD, met Time machine backups en blijkbaar ook 7 snapshots.

En de veilige modus heb ik niet uitgeprobeerd: ik ben vanochtend opnieuw opgestart, een tweede poging om in mijn userprofile te komen had hetzelfde resultaat. Opnieuw opgestart (na stroom eraf) en ingelogd in het andere adminprofile, daar EHBO uitgevoerd, opnieuw opgestart en ingelogd op mijn eigen userprofile. Dat bleef weer steken, maar een uur later was ik ineens toch normaal ingelogd. En van daar uit type ik dit nu ...
geplaatst door: Heintje
antw: Kan je een userprofile repareren?
reactie #4 geplaatst: 11 augustus 2019 - 14:19
Etrecheck rapportje vanuit dit account maken? Geen garantie tot succes maar je moet ergens beginnen. Kun je herinneren of je iets veranderd of geïnstalleerd hebt voordat dit gebeurde? Nu je weer in je account zit, doet Mail het normaal en heb je die eens afgesloten en weer opgestart?

Als je lokale snapshots heb zou je er een terug kunnen zetten van een paar dagen geleden, dat duurt maar een paar minuten. 
geplaatst door: boiing
antw: Kan je een userprofile repareren?
reactie #5 geplaatst: 11 augustus 2019 - 18:09
Mail gedraagt zich normaal en laat zich ook gewoon afsluiten en opstarten.
Ik heb gisteren niets geïnstalleerd, ook geen updates: gewoon wat gemaild en ge-internet, meer niet.
Ik vind het onverklaarbaar. Vanavond moet ik uitloggen (omdat iemand op zijn account moet) en morgen zal ik kijken hoe e.e.a. zich dan gedraagt.
geplaatst door: Heintje
antw: Kan je een userprofile repareren?
reactie #6 geplaatst: 11 augustus 2019 - 19:16
Waarom moet je dan uitloggen? Je kunt toch gewoon met meerdere accounts tegelijk inloggen?
Hier staat een Mac in de woonkamer waar doorgaans tussen de 2 en 4 accounts op ingelogd zijn...

Tenzij je dat uit hebt staan, dan kun je het aanzetten in systeemvoorkeuren -> Gebruikers en Groepen.
Links-onderin staan "Inlogopties" en daar moet je "Menu voor snelle gebruikersoverschakeling" aanzetten. Je krijgt dan rechtsboven een menu waarmee je tussen gebruikers kunt wisselen.

(niet dat dat je probleem oplost, maar je krijgt wel weer wat bedenktijd...)
geplaatst door: jaco123
antw: Kan je een userprofile repareren?
reactie #7 geplaatst: 12 augustus 2019 - 17:31
Dat bleek al aan te staan, maar ook na 10 jaar wist ik nog niet dat dat zo werkte ...   :shocked:
Dat gaan we zo gebruiken.

En het inloggen verloopt weer foutloos en snel.
Geen idee wat het is geweest, maar het euvel is nu verdwenen.
geplaatst door: Heintje