Ik moet nodig aan een nieuwere Mac. Ik heb nu nog iMac5,1 en ik loop tegen allerlei disfuncties aan.
Maar als ik allemaal nieuwe programma's moet installeren gaat me dat veel geld kosten, vrees ik.
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #1 geplaatst: 24 oktober 2020 - 12:11
Dat ligt helemaal aan de software, en kun je bij de maker opzoeken. Vooral met Catalina 10.15 zul je problemen krijgen want daarin werkt alleen 64-bit software. Als jij nog met Snow Leopard werkt zul je ook nog veel 32-bit software of drivers gebruiken. Die moeten dan allemaal een update krijgen.

De vraag is te algemeen om er verder veel over te kunnen zeggen: het hangt helemaal van de software af die je bedoelt of er een update is en of die betaald moet worden.
geplaatst door: boiing
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #2 geplaatst: 24 oktober 2020 - 12:14
Een "Late 2006", dat is inderdaad al een oudje. (Niks ten nadele van oudjes, ik heb nog een 17" MBP van die generatie.)

Over welke programma's heb je het dan?

Een aantal programma's waar je vroeger extra voor moest betalen (iWork etc) wordt al jaren standaard meegeleverd (Keynote, Numbers, Pages).
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #3 geplaatst: 24 oktober 2020 - 12:19
Het gaat om Adobe CS3, QuarkXpress 9, Freeway 6.1.2
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #4 geplaatst: 24 oktober 2020 - 12:26
Freeway ken ik niet (bestaat al een paar jaar niet meer zo te zien), voor die andere 2 zul je de portemonnee moeten trekken vrees ik. Bovendien zijn het abonnementen tegenwoordig, weet niet of je dat wist..
geplaatst door: boiing
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #5 geplaatst: 24 oktober 2020 - 12:34
https://www.softpress.com/freeway-pro/index.html

Citaat

Freeway and Catalina (macOS 10.15)

Freeway is a 32-bit application. It won't run under the latest version of macOS (10.15 Catalina) because Apple have dropped support for 32-bit applications and have abandoned many of the system APIs that Freeway uses.

We have developed Xway as a replacement for Freeway.

Development of Xway is progressing apace, but it's going to take a while before it is a complete replacement for Freeway 7. There could be a transitional period in which you may want to keep Mojave on a separate partition for when you need to run Freeway 7 (or other 32-bit software).

Another option is to run Mojave in a VM, such as VMware Fusion or Parallels Desktop.




https://www.softpress.com/xway/index.html

Citaat

Xway for macOS, the next-generation web-design tool is finally here. 64-bit and Catalina-ready, Xway takes the best from the web-design tool you love and combines it with the things you've always wanted.

antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #6 geplaatst: 24 oktober 2020 - 12:36
Van de andere kant: die programma's werken hoogstwaarschijnlijk nog wel onder High Sierra 10.13. Als je daar dus officiële versies van hebt kun je overwegen een wat oudere 'nieuwe' Mac aan te schaffen die High Sierra draait. Dat is een beetje behelpen, maar wel een stuk voordeliger.
geplaatst door: boiing
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #7 geplaatst: 24 oktober 2020 - 12:42
...een wat oudere 'nieuwe' Mac aan te schaffen die High Sierra draait.

Een Mid 2017 iMac bijvoorbeeld, die destijds met macOS 10.12 (Sierra) verkocht werd (en natuurlijk ook alle latere macOS versies kan gebruiken).
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #8 geplaatst: 24 oktober 2020 - 12:47
Freeway ken ik niet (bestaat al een paar jaar niet meer zo te zien), voor die andere 2 zul je de portemonnee moeten trekken vrees ik. Bovendien zijn het abonnementen tegenwoordig, weet niet of je dat wist..
Van die abonnementen dat weet ik en dat is best vervelend. Ik gebruik die programma's wel maar zo nu en dan, niet echt professioneel meer. Dan zijn die abonnementen duur.
QuarkXpress zal nog gaan met versie 10 die ik wel heb maar niet kan installeren op deze Mac. Dat Freeway niet meer bestaat dat wist ik niet. Ook een beste tegenvaller. Ik denk dus dat ik deze iMac maar blijf gebruiken met de programma's die er op staan en voor de functionaliteit met internet iPad aanschaf.
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #9 geplaatst: 24 oktober 2020 - 12:51
Een Mid 2017 iMac bijvoorbeeld, die destijds met macOS 10.12 (Sierra) verkocht werd (en natuurlijk ook alle latere macOS versies kan gebruiken).
Dat klinkt hoopgevend. Maar draait CS3 op Sierra of moet dat geupdated worden ?
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #10 geplaatst: 24 oktober 2020 - 12:53
Dat Freeway niet meer bestaat dat wist ik niet..
Lees even wat puk1980 daarover quote, de oude versie werkt blijkbaar gewoon behalve op Catalina, en er is een vervanger.. Zou dus ook geen probleem zijn op High Sierra.

Maar draait CS3 op Sierra of moet dat geupdated worden ?
Ik heb het niet uitgebreid onderzocht, maar wat ik even snel las was dat CS3 inderdaad op High Sierra draait.
geplaatst door: boiing
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #11 geplaatst: 24 oktober 2020 - 12:56
Dat klinkt hoopgevend.

Je kunt nog refurbished 2017 iMacs met garantie kopen. Kost wel wat, maar dan kun je ook weer een aantal jaren vooruit.
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #12 geplaatst: 24 oktober 2020 - 12:57
Lees even wat puk1980 daarover quote, de oude versie werkt blijkbaar gewoon behalve op Catalina, en er is een vervanger.. Zou dus ook geen probleem zijn op High Sierra.
Ik heb het niet uitgebreid onderzocht, maar wat ik even snel las was dat CS3 inderdaad op High Sierra draait.
Dat is fijn om te horen. Dank je.
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #13 geplaatst: 24 oktober 2020 - 13:00
In aanvulling op puk1980: hier staat er ook een. Prima adresje :wink:.

https://macfreak.nl/shop/mac/refurbished-macs/imac-27-/imac-retina-5k-27-inch-2017--1
geplaatst door: boiing
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #14 geplaatst: 24 oktober 2020 - 13:03
Maar draait CS3 op High Sierra of moet dat geupdated worden ?

Ja dat werkt, met enkele mitsen en maren, uitgelegd in het artikel:
https://blog.conradchavez.com/2017/09/25/macos-10-13-high-sierra-will-adobe-software-work/

TL;DR: Je hebt weer even Java nodig om de installatie uit te kunnen voeren.
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #15 geplaatst: 24 oktober 2020 - 13:06
Hier staat er ook een. Prima adresje :wink:.
+1!
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #16 geplaatst: 24 oktober 2020 - 13:24
Dank allemaal. Ik kom er nu wel uit. Geweldige informatie. You made my day.
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #18 geplaatst: 25 oktober 2020 - 15:39
Ik heb het gelezen, klinkt niet bemoedigend. Maar met de migratieassistent kun je die programma's tot simpel installeren zonder dat je ze weer moet activeren?
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #19 geplaatst: 25 oktober 2020 - 21:52
Kijk eens naar de 'suite' van Affinity. Dat kost een fractie van Adobe en is (vrijwel) net zo goed en soms beter. Ze hebben inmiddels een flink stuk van de markt veroverd. Quark vervang je (dus) door Affinity Publisher. Er komen geregeld aanbiedingen voorbij met 30%-50% korting, dus als je geen haast hebt...

WordPress is tegenwoordig zo ongeveer de standaard in webdesign. Maar het kan uiteraard op vele andere manieren. Lees misschien dit artikel eens als je er niet uitkomt met Freeway/XWay. NB. Ik heb in een grijs verleden met Freeway Pro wel wat gedaan en was persoonlijk niet kapot van de features en stabiliteit.
geplaatst door: Max Gaav
My Mac is my second brain.
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #20 geplaatst: 26 oktober 2020 - 11:38
Dankje Max, goeie tip. Ga ik zeker gebruik van maken.
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #21 geplaatst: 25 november 2020 - 12:50
Kijk eens naar de 'suite' van Affinity. Dat kost een fractie van Adobe en is (vrijwel) net zo goed en soms beter. Ze hebben inmiddels een flink stuk van de markt veroverd. Quark vervang je (dus) door Affinity Publisher. Er komen geregeld aanbiedingen voorbij met 30%-50% korting, dus als je geen haast hebt...

WordPress is tegenwoordig zo ongeveer de standaard in webdesign. Maar het kan uiteraard op vele andere manieren. Lees misschien dit artikel eens als je er niet uitkomt met Freeway/XWay. NB. Ik heb in een grijs verleden met Freeway Pro wel wat gedaan en was persoonlijk niet kapot van de features en stabiliteit.
Nogmaals bedankt Max. Inmiddels heb ik een nieuwere Mac. Daarop draait Yosemite 10.10.5. Vrijwel alles werkt. Ik heb ook Affinity Publisher geïnstalleerd. Geweldig programma. Alleen de interface is nogal petieterig.
Zelfs QuarkXpress 9 werkt maar niet met graagte. Ik moet een aantal keer opstarten voordat ie actief wordt.
Hij stribbelt tegen, zeg maar. Opnieuw installeren lukt niet net zo min met versie 10. Van beide heb ik een licentie, legaal. Hij geeft bij installeren een bericht van: "Minimum system OS required is Mac OS® 10.5.8 (Leopard®), Mac OS 10.6.4 (Snow Leopard®) or later" en sluit dan af.
QXP wil me niet helpen die willen liever verhuren en daar heb ik geen behoefte aan, kost ook weer teveel. Ik kan me prima redden met deze versies. Het feit dat versie 9 wel werkt betekent dat het systeem er in principe geen probleem mee heeft. Heb jij een idee waarom dat installeren niet lukt ?
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #22 geplaatst: 25 november 2020 - 12:57
Misschien relevant:

You can no longer reinstall CS 2 or 3 even if you have the original disks.

https://helpx.adobe.com/creative-suite.html
Hi, in the meantime I have a newer iMac with Yosemite and CS3 works fine on it after migration and I have even reinstalled some parts of it. Only QuarkXpress is troubling but it also works after some boots.
geplaatst door: Cor Heilig
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #23 geplaatst: 25 november 2020 - 14:04
Puk 1980 spreekt toch Grieks?
geplaatst door: Flix
antw: Werken programma's vanaf macOS 10.6.x ook in 10.7xx en later?
reactie #24 geplaatst: 25 november 2020 - 14:55
Puk 1980 spreekt toch Grieks?
Ohh, wist ik niet :D :D
geplaatst door: Cor Heilig